AnimeBlogger.net Forums Forum Index AnimeBlogger.net Forums
Anime/Manga Blogging Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fixing your poll plugin

 
Post new topic   Reply to topic    AnimeBlogger.net Forums Forum Index -> General Chat
View previous topic :: View next topic  
Author Message
akurashy



Joined: 28 Aug 2006
Posts: 15
Location: Melon bread factory!

PostPosted: Sun Nov 19, 2006 8:51 am    Post subject: Fixing your poll plugin Reply with quote

Well since yesterday impz and aurabolt tells me that their poll was not working correctly, this includes the majority of the blogs that are hosted in AB using the WP-Polls by gamerz


ERROR GENERATED BY POLL PLUGIN IS THIS ONE:


WordPress database error:
[Table 'xxx.wp_pollsip' doesn't exist]
SELECT pollip_aid FROM wp_pollsip WHERE pollip_qid = 6 AND pollip_ip = 'xx.xx.xxx.xxx'

Okay here's a bit of the hard part and that is, finding your sql database name, which Maestro should have email the info when setting up the accounts Mad

Go to Ftp and open your wp-config ->
You notice all variables and definitions and so on blah blah blah notice the
define('DB_HOST', 'YOURDBNAME.animeblogger.net');

ex. paste YOURDBNAME.animeblogger.net in your address bar


Copy that url, yes like an url, go to that url directly and it asks you for user and password, NOW, Do not use the current user and password you always use. Just look at the wp-config.php and copy the following things

Your user is located in
define('DB_NAME', 'YOURDBNAMEHERE');

that's your username right there. copy 'YOURDBNAMEHERE' , without the quotes then same process when taking the password.

Press enter, now it guides you to phpMyAdmin, it's a sql webbased management etc etc.

In the sidebar, press the selection form, and look for your database, it should be named the same as your DBUSER.

You notice the little tabs up there? Cool then just go to SQL tab and paste the following code
    Edit (Maestro4k): Removed code, please see my reply as to why and what you should do if this problem has affected your blog.
Press go and that should do it, go back to your blog check it out or ask the same person who had the problem to go there, it should be fixed .
_________________
Shuffled Thoughts! (Yet another anime blog o.o)
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger
Maestro4k
Site Admin


Joined: 04 Jun 2005
Posts: 1397

PostPosted: Sun Nov 19, 2006 7:21 pm    Post subject: Reply with quote

Actually, if your poll's showing the SQL error you should contact me instead of trying to repair it. It turns out that this particular polls plugin is written very badly and is thrashing the database servers, causing performance problems for everyone (and even people besides those hosted at AB). What it boils down to is that if your poll's displaying the error, my hosting provider had to disable that particular table because it was impacting database performance. They won't actually disable any table unless it's causing a major problem, so if you add it back it'll end up disabled again.

The problem is two-fold, first the author of the plugin apparently doesn't understand how to interact with the database properly, the queries from the poll software do not allow for indexing so the performance issue cannot be solved on the database side. Secondly it appears that someone (or multiple people) are trying to abuse the polls, attempting to stuff the ballot box as it were. They're hitting the database with literally hundreds of queries a minute, all against the wp_pollsip table.

Do note that if the error has shown up for you then the poll plugin was slowing down your blog, probably noticeably.

So to sum up, don't fix it yourself, E-mail me about it. In the future I hope to try to fix the plugin myself so that its database accesses can be fixed and allow for indexing on the database to solve the whole thing. In the meantime the only solution is to stop using this plugin. You don't need to stop using it if you don't have any errors showing, but if you're seeing them, contact me immediately. I'm behind in trying to sort the whole issue out, it just came up a few days ago. Sad
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    AnimeBlogger.net Forums Forum Index -> General Chat All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

Page created in 0.089 seconds with 23 SQL queries
  Username:    Password:      Remember me